[Support requis] Inscription impossible

7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #8307
    Photo du profil de Nicolas Poitier
    Nicolas Poitier
    Participant

    Bonjour,
    Alors j’utilise
    Default InstantWP Installation running InstantWP 4.5 with
    WordPress 4.3.1 / Apache/2.2.15 (Win32) / PHP/5.3.2 / MySQL 5.6.25
    Buddypress Version 2.3.3
    Thème Twenty twelve

    Lorsque je désactive Buddypress je n’ai aucun problème pour l’inscription de nouveaux utilisateurs…
    Mais avec Buddypress: lorsque je me déconnecte et que j’utilise la page d’inscription, lors du clic sur le bouton, il ne se passe rien. Pas de nouvel utilisateur, pas de nouvelle inscription (0 en attente)
    Lorsque je demande l’affichage des pages inscription ou Activation depuis la configuration de Buddypress, je me retrouve sur la page d’acceuil…
    Quelqu’un peut il me venir en aide? Je viens de passer l’aprem et une partie de la nuit à chercher et je craque « un peu » 😉

    Je n’ai rien modifier d’autre: pas d’autre extension active (faut dire que j’ai tout réinitialisé pour faire du pas à pas)

    #8308
    Photo du profil de Dan
    Dan
    Admin bbPress

    Bonjour,

    d’abord, les infos à propos de ton site sont à mettre sur ton profil, il est là pour ça.
    Ensuite, un truc important à vérifier avant de poursuivre. La version php du serveur est bien 5.3.2 ? Si c’est le cas, essaye d’obtenir une version récente, sinon, change d’hébergeur tout de suite. La dernière maintenance de php 5.4 est parue cette semaine, pour accompagner sa fin de vie! Actuellement, la version stable affiche 5.6.12

    Pour que l’inscription/activation de compte fonctionne quand BP est activé, il faut créer manuellement ces 2 pages et leur attribuer un titre. Ensuite il suffit de les sélectionner depuis la dropbox Pages en face de activation et enregistrement depuis l’admin BuddyPress. Ces 2 pages ne sont jamais activées par défaut, contrairement aux 3 autres strictement destinées à BuddyPress.

    Pour finir, il faut aussi activer les permaliens, en sélectionnant une des options, sauf celle par défaut.
    Et si ça ne marche toujours pas, vérifier que le fichier htaccess est présent, et qu’il a bien été rempli lors de l’activation de WordPress. Si ce n’est pas le cas, tu jettes le fichier wp-config et htaccess et tu relances l’install de WP. Ca ne détruiras rien dans la base, mais cela relancera la création du htaccess.

    #8310
    Photo du profil de Nicolas Poitier
    Nicolas Poitier
    Participant

    Re,

    Merci pour les options de profil, je vais régularisé ça dès que j’ai 2 mn
    Bon, les pages avaient été créées (par moi), quand je disais « lorsque je demande l’affichage des pages inscription ou Activation depuis la configuration de Buddypress, je me retrouve sur la page d’acceuil… », c’est à elle que je faisais référence… En même temps, comme je les lance depuis le paneau d’administration en étant loggé, je me demande si ce n’est pas normal finalement comme comportement…

    Reste donc la montée de version du PHP… Je vais tester ça, j’ai aussi un serveur wamp 2.2 sur ma machine…

    le htacces me paraît bon:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress

    et le wp-config ne me paraît pas contenir d’incongruités…

    Je tente tout de suite la solution d’install avec PHP de version supérieure…
    Pour ma défense, l’install dont je parlais au début est celle de InstantWP 4.5 (je ne vois pas comment y changer la version de PHP ^^)

    #8311
    Photo du profil de Nicolas Poitier
    Nicolas Poitier
    Participant

    catastrophe! ^^
    J’ai installé WampServer Version 2.5…
    Quand j’active les permaliens (Date et titre par exemple), je perds l’accès au pages: The requested URL /nanterre/page-d-exemple/ was not found on this server.

    ça pète de partot dès qu’on fait qqch… ^^

    #8312
    Photo du profil de Nicolas Poitier
    Nicolas Poitier
    Participant

    désolé, c’était le mode rewrite du seveur…
    Pardon

    #8313
    Photo du profil de Dan
    Dan
    Admin bbPress

    Apparemment tu utilises une install « clé en main » de WordPress… Pas terrible à mon humble avis. Mieux vaut faire cela soi-même via FTP, les outils d’automatisation de cette tâche n’étant pas toujours à jour.

    Pour le htaccess, il me semble bon en effet, hormis qu’une redirection vers un répertoire wordpress est discutable.
    Sur une install standard, même en local ou sur un mutualisé, WP devrait se trouver à la racine. Dans ce cas RewriteBase /wordpress/ devrait être RewriteBase / et RewriteRule . /wordpress/index.php [L] serait RewriteRule . /index.php [L] Mais c’est un détail qui n’a rien à voir avec ton histoire de page qui renvoie sur la home… Encore que…

    Il y a cependant un autre truc à vérifier si tu es sous Windows en local. Il faut configurer un/des virtual host le fichier systeme C:\Windows\System32\drivers\etc\HOSTS quand tu utilises Apache > 2.2. parce que Wamp ne le fait pas automatiquement.

    
    # localhost name resolution is handled within DNS itself.
    127.0.0.1       localhost
    ::1             localhost
    
    127.0.0.1       site1
    ::1             site1
    
    127.0.0.1       site2
    ::1             site2
    
    et ainsi de suite pour chaque site en local

    En local, tu pourrais te passer de InstantWP 4.5. Ca ne te coûterais rien d’essayer en tous cas et ce sera toujours un plugin de moins à gérer. Pour le site de production, je ne peux rien pour toi. Va falloir te débrouiller avec la doc de l’hébergeur ou prendre contact directement.

    #8314
    Photo du profil de Nicolas Poitier
    Nicolas Poitier
    Participant

    Ok, maintenant tout va bien sur cette install (buddypress et bbpress)
    J’aurai bien voulu savoir ce qui cloche sur l’autre, (sauf si c’est la version du PHP), mais bon tant pis…
    En tout cas merci, c’est tout bon pour moi, reste à faire le css perso et à installer User Role Editor!

7 sujets de 1 à 7 (sur un total de 7)
  • Le sujet ‘Inscription impossible’ est fermé à de nouvelles réponses.
Aller à la barre d’outils