[Support requis] Problème de membre mis en attente depuis wp 4.7

Ce sujet a 2 réponses, 2 participants et a été mis à jour par Photo du profil de Julien Julien, il y a 5 mois.

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #9608
    Photo du profil de Julien
    Julien
    Participant

    Bonjour,

    Depuis la mise à jour de wordpress, les nouveaux membres inscrit sur mon site sont mis en attente, normalement ça devrais le faire en automatique grâce au code suivant (via bp-custom.php)

    function disable_activation_email() {
    return false;
    }
    add_filter( 'bp_core_signup_send_activation_key', 'disable_activation_email' );
    
    /// Désactive la fonction mail
    add_filter( 'bp_registration_needs_activation', '__return_false' );

    Autre chose par rapport à cette nouvelle version de WordPress, PHP 7.1 passe pas uniquement avec les profils buddypress (erreur 500), d’après mes sources, l’équipe de Buddypress sont en train de voir pour corriger le souci ?

    #9609
    Photo du profil de Dan
    Dan
    Admin bbPress

    Bonjour,

    je crois que la première fonction ne filtre rien si elle retourne uniquement false. A mon avis, il faut au moins un user_id.
    Voir référence

    Pour la seconde, je ne comprend pas: elle marche ou pas ? Globalement, je ne suis pas certain que le fait de ne pas envoyer le mail d’activation suffit à mettre les utilisateurs en attente. Mais je ne suis pas développeur, mon avis est donc très subjectif….

    Les stats WP indiquent que 28,7% des sites wordpress au monde utilisent encore php 5.6. Ce sont les plus nombreux face à ceux sous php 7 (4.3%)

    Et en effet, BP n’est pas prêt pour PHP 7.1. Ceci dit ce n’est pas un problème. PHP 7 a tout juste un an, la plupart des serveurs mutualisé ont été màj début 2016, un bom tiers des utilisateurs est en formation pour pouvoir utiliser cette version et les grands logiciels open source comme WP (basés sur le volontariat) font de leur mieux pour assurer la rétro-compatibilité et coller à la dernière version stable (donc 7.0.0) Et toi tu arrives avec ton 7.1, publié début décembre 2016 !

    Hé, ho, molo, y’a pas le feu ! Et je confirme que les devs de BP sont bien sur le coup (comme d’hab’). Tu t’abonnes à ce ticket, si le sujet te passionne.

    #9610
    Photo du profil de Julien
    Julien
    Participant

    Cela ne fonctionne pas, les membres sont en attente, une intervention de l’admin est obligatoire pour activer son compte, il y avait pas ce problème avant la mise à jour de WP ! Les codes indiqué on été récuperer sur le net (je sais plus ou), n’étant pas du tout un dév, je ne sais pas quoi faire. Par contre, pas de mail d’activation envoyé à l’utilisateur donc le code fonctionne bien, tout ce que je veux c’est que chaque nouveau membre ne soit pas en attente.

    La vesion 7.1 est un peu plus rapide, j’ai tester sur mes pages et je constate une différence de réactivité ! Bref c’est pas grave, je suis patient.

3 sujets de 1 à 3 (sur un total de 3)

Le sujet ‘Problème de membre mis en attente depuis wp 4.7’ est fermé à de nouvelles réponses.

Aller à la barre d’outils